Eclipse 에서 @override 에서 에러 날 때

Posted 2008. 11. 23. 14:41 by 카메란

언제부터인가

Eclipse 에서  @override 에서 에러 마커가 떴다..

분명히 그 전부터 멀쩡히 에러 마커가 안 뜬 소스였다..



구글링을 해보니

Java 5.0까지는 @override를

interface 의 method를 implement 할 때  사용 못하는데,

6.0 부터는 위의 경우에도 사용할 수 있다는 것이었다..


그러자 생각난 것이,

얼마전에

[Window] - [Preference] 에서

Java- Compiler 에서

Compiler compliance level 을  1.5 로 바꾼것이 생각 났다..

그래서 이걸 다시 1.6으로 바꿨더니,

에러가 사라졌다...


아래는 수정한 부분..

사용자 삽입 이미지





Tag : ,

  1. | 2012.09.13 14:03 | PERMALINK | EDIT | REPLY |

    항상 이걸로 고생했는데, 따라해보니 잘되네요 감사합니다!

  2. 비비

    | 2012.10.11 17:13 | PERMALINK | EDIT | REPLY |

    감사함당!

Write your message and submit
« PREV : 1 : ··· : 69 : 70 : 71 : 72 : 73 : 74 : 75 : 76 : 77 : ··· : 188 : NEXT »